Angry Creature


Requires Unity 5.0 or higher. (Also comes with FBX files to be used with any Game Engine)

Poly Count: See Screenshot

End User License Agreement


Ridiculously awesome flying alien creature!

Click here for Unity 3D Preview



There are no reviews yet.

Only logged in customers who have purchased this product may leave a review.

Pin It on Pinterest

Share This